Skip to content
major vulnerability· requires attention

CakePHP is a widely used web framework; a high-severity SQL injection in core expression handling can compromise many web apps and databases across organizations.

Web

CVE-2026-119419

9.2
Critical
EPSS 0.39%Patch availableOct 31, 2026

SQL injection in CakePHP collation handling allows injection via COLLATE

common questions

Is CVE-2026-119419 being exploited?

Not confirmed. CVE-2026-119419 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.39% probability of exploitation in the next 30 days.

How severe is CVE-2026-119419?

CVE-2026-119419 is rated Critical with a CVSS score of 9.2. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-119419?

Yes. A fix has been recorded for CVE-2026-119419. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-119419 affect?

CVE-2026-119419 affects CakePHP <= 5.4.3, Web applications using affected CakePHP versions, All DB drivers accessible by the application. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-119419?

Upgrade to patched CakePHP (>5.4.3) or apply vendor commits; restrict DB privileges and audit inputs.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
CakePHP <= 5.4.3Web applications using affected CakePHP versionsAll DB drivers accessible by the application
impact

Attacker-controlled collation values can append SQL after COLLATE, enabling data exfiltration, modification, or DB takeover within connection privileges.

action required

Immediate action required

affected versions
cakephp
  • affected<= 5.4.3

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved