Brotli is widely embedded in browsers, servers, CDNs and runtimes; a remote RCE/DoS in a common compression lib impacts broad web infrastructure and enterprise software.
CVE-2026-111497
Buffer overflow in Brotli decoder enables memory disclosure, DoS, or potential RCE.
Can a WAF block it? Partly. Cloudflare publishes WAF rules written for this CVE. Such rules block the known exploit requests and buy time, but attackers can change the request to get past them, so they do not replace the patch.
Cloudflare · 2 rules (Log) · since 25 Oct 2026
- Next.js - Image Optimizer Path - CVE:CVE-2026-111497 · Cloudflare Managed Ruleset
- Brotli - Request Content-Encoding - CVE:CVE-2026-111497 · Cloudflare Managed Ruleset
Also consider: patch · enable the vendor rule in block mode
Based on WAF vendor rules published for this CVE. We check Cloudflare, AWS, Google Cloud Armor and Azure; for Akamai, Imperva, Fastly, F5, ask your vendor.
Is CVE-2026-111497 being exploited?
Yes. CVE-2026-111497 appears in CISA's Known Exploited Vulnerabilities catalog, which means exploitation in the wild has been confirmed and reported. Treat it as active rather than theoretical, and patch it ahead of higher-scoring vulnerabilities that carry no exploitation evidence.
How severe is CVE-2026-111497?
CVE-2026-111497 is rated Critical with a CVSS score of 9.2. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-111497?
Yes. A fix has been recorded for CVE-2026-111497. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-111497 affect?
CVE-2026-111497 affects Google Brotli 1.0.3–1.2.0, Web browsers embedding Brotli, Node.js builds using vulnerable Brotli, Web servers, proxies, CDNs using Brotli, and 1 further product or version. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-111497?
Upgrade Brotli to 1.0.10 / 1.1.1 / 1.2.1, rebuild and deploy; scan and patch dependent binaries.
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Remote unauthenticated crafted Brotli stream can cause out‑of‑bounds memory writes leading to memory disclosure, denial of service, or potential remote code execution.
Immediate action required
- affected>= 1.0.3 and < 1.0.10
- affected>= 1.1.0 and < 1.1.1
- affected>= 1.2.0 and < 1.2.1
As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.