SQLite is a widely embedded database engine across OSes and apps; a heap overflow that can crash or possibly enable code execution merits broad attention.
CVE-2026-119374
Heap buffer overflow in SQLite FTS5 secure-delete causing crashes and possible code execution.
Is CVE-2026-119374 being exploited?
Not confirmed. CVE-2026-119374 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.18% probability of exploitation in the next 30 days.
How severe is CVE-2026-119374?
CVE-2026-119374 is rated High with a CVSS score of 8.5. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-119374?
Yes. A fix has been recorded for CVE-2026-119374. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-119374 affect?
CVE-2026-119374 affects SQLite < 3.54.0, Applications embedding SQLite with FTS5 enabled and secure-delete configured, Desktop, mobile, server apps that open untrusted DB files. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-119374?
Upgrade to SQLite 3.54.0+ and rebuild/redeploy apps using FTS5 secure-delete.
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Crafted FTS5 index with secure-delete triggers heap overflow, causing app crashes and potentially arbitrary code execution/memory corruption.
Patch when possible
- affected< 3.54.0
As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.