Skip to content
major vulnerability· requires attention

Kernel-level networking bug (mlx5e) with CVSS 9.8 affects Linux servers/cloud using Mellanox NICs; can disrupt infrastructure and is broadly relevant to IT/infra teams.

Systems

CVE-2026-99079

9.8
Critical
EPSS 0.46%Patch availableOct 25, 2026

Linux mlx5e AF_XDP bug causes double-free/data corruption in XDP refill path

common questions

Is CVE-2026-99079 being exploited?

Not confirmed. CVE-2026-99079 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.46% probability of exploitation in the next 30 days.

How severe is CVE-2026-99079?

CVE-2026-99079 is rated Critical with a CVSS score of 9.8. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-99079?

Yes. A fix has been recorded for CVE-2026-99079. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-99079 affect?

CVE-2026-99079 affects Linux kernel (mlx5e driver), Servers using Mellanox/ConnectX NICs, Systems using AF_XDP/XDP with legacy cyclic RQ, Cloud hosts and appliances with affected kernels. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-99079?

Install vendor/upstream kernel updates with mlx5e fixes and reboot affected hosts.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Linux kernel (mlx5e driver)Servers using Mellanox/ConnectX NICsSystems using AF_XDP/XDP with legacy cyclic RQCloud hosts and appliances with affected kernels
impact

Triggerable via XDP->AF_XDP RX path: kernel memory corruption/double-free leading to DoS (kernel crash) and possible local privilege escalation or arbitrary code execution.

action required

Immediate action required

affected versions
Linux Linux
  • affected>= 3f93f82988bc6b4104314bf9aa485d47fbb7e241 and < 32bbb870078d467479965c21bbc4960c57eea208
  • affected>= 3f93f82988bc6b4104314bf9aa485d47fbb7e241 and < 34d1db2b18e1c1d189e34dd51923e031815f88e3
  • affected>= 3f93f82988bc6b4104314bf9aa485d47fbb7e241 and < 639522e5056cade578a324acfa993ec6c9f7f5dc
  • affected>= 3f93f82988bc6b4104314bf9aa485d47fbb7e241 and < 655f47477054d19de3b138840be229a1a4490d0c
  • affected>= 3f93f82988bc6b4104314bf9aa485d47fbb7e241 and < e01620844c5c88b6fcf819d171df8e3976a0e76f
  • affected6.4
vendor says fixed in< 6.4, >= 6.6.160 and <= 6.6.*, >= 6.12.113 and <= 6.12.*, >= 6.18.57 and <= 6.18.*, >= 7.2.11 and <= 7.2.*, >= 7.3 and <= *

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved