Skip to content
major vulnerability· requires attention

Kernel networking driver bug in widely deployed Linux kernels (mlx5e/AF_XDP) enabling remote kernel compromise; impacts servers, cloud hosts and NICs used across enterprises.

Networks

CVE-2026-99078

9.8
Critical
EPSS 0.46%Patch availableOct 25, 2026

Linux mlx5e AF_XDP bug allows kernel memory corruption via stale XSK buffers

common questions

Is CVE-2026-99078 being exploited?

Not confirmed. CVE-2026-99078 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.46% probability of exploitation in the next 30 days.

How severe is CVE-2026-99078?

CVE-2026-99078 is rated Critical with a CVSS score of 9.8. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-99078?

Yes. A fix has been recorded for CVE-2026-99078. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-99078 affect?

CVE-2026-99078 affects Linux kernel (mlx5e driver with AF_XDP), Systems with Mellanox/ConnectX (mlx5) NICs, Servers and cloud hosts running affected kernels. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-99078?

Apply kernel patches containing the mlx5e fix and reboot affected hosts immediately

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Linux kernel (mlx5e driver with AF_XDP)Systems with Mellanox/ConnectX (mlx5) NICsServers and cloud hosts running affected kernels
impact

Remote kernel memory corruption leading to potential remote code execution or system crash via crafted network traffic

action required

Immediate action required

affected versions
Linux Linux
  • affected>= 4c2a1323680709078736a2886c754004e9fe42e6 and < f3a52e2ec2788a7f6b64137985c087188a54ad4f
  • affected>= 4c2a1323680709078736a2886c754004e9fe42e6 and < d215d09606b0fcd18ad1eb532995782a21cea49d
  • affected>= 4c2a1323680709078736a2886c754004e9fe42e6 and < 867119b4b588037724b85839d534465f0334d9bd
  • affected>= 4c2a1323680709078736a2886c754004e9fe42e6 and < 3d73a1164a8c6b4461907a65cb6c022ea4fd39af
  • affected>= 4c2a1323680709078736a2886c754004e9fe42e6 and < 63811edf512584c946e5e96b100e9e280703bbb5
  • affected6.4
vendor says fixed in< 6.4, >= 6.6.160 and <= 6.6.*, >= 6.12.113 and <= 6.12.*, >= 6.18.57 and <= 6.18.*, >= 7.2.11 and <= 7.2.*, >= 7.3 and <= *

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved