Skip to content
major vulnerability· requires attention

Kernel-level race affecting mount namespaces can break container/namespace isolation on widely deployed Linux systems; high-impact for servers and multi-tenant environments.

Systems

CVE-2026-98981

8.8
High
EPSS 0.16%Patch availableOct 24, 2026

Linux VFS dentry race can expose overmounted/unlinked files across mount namespaces

common questions

Is CVE-2026-98981 being exploited?

Not confirmed. CVE-2026-98981 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.16% probability of exploitation in the next 30 days.

How severe is CVE-2026-98981?

CVE-2026-98981 is rated High with a CVSS score of 8.8. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-98981?

Yes. A fix has been recorded for CVE-2026-98981. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-98981 affect?

CVE-2026-98981 affects Linux kernel (affected stable versions prior to patch), Containers and systems using mount namespaces. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-98981?

Install kernel updates and reboot hosts; isolate untrusted containers until patched

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Linux kernel (affected stable versions prior to patch)Containers and systems using mount namespaces
impact

Local race allows attackers to read underlying files after mount removal, breaking mount-namespace isolation and enabling data disclosure or container escape.

action required

Patch when possible

affected versions
Linux Linux
  • affected>= 8ed936b5671bfb33d89bc60bdcc7cf0470ba52fe and < db90eecbde319527aa9480c039d32a0f5fe80574
  • affected>= 8ed936b5671bfb33d89bc60bdcc7cf0470ba52fe and < 8d71bfc9b3fc15d7103e82ea9dc5057541866e46
  • affected>= 8ed936b5671bfb33d89bc60bdcc7cf0470ba52fe and < d29cd99db3db74cf3447be74d25740981789d461
  • affected>= 8ed936b5671bfb33d89bc60bdcc7cf0470ba52fe and < 8300de4aa5d09061bfcf2af5b52c0cdba3873185
  • affected>= 8ed936b5671bfb33d89bc60bdcc7cf0470ba52fe and < 528b383dc35d1e5caf64ddf5d35f983ae543b0d0
  • affected3.18
vendor says fixed in< 3.18, >= 6.6.160 and <= 6.6.*, >= 6.12.114 and <= 6.12.*, >= 6.18.57 and <= 6.18.*, >= 7.2.11 and <= 7.2.*, >= 7.3 and <= *

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved