Critical auth-bypass in widely used RabbitMQ broker (OAuth2 plugin) enabling JWT acceptance via MITM; impacts many orgs using RabbitMQ, warrants broad IT/infra notification.
CVE-2026-67404
RabbitMQ OAuth2 accepts forged JWTs when CA bundle missing, allowing authentication bypass.
do firstUpgrade to a fixed release: 3.13.15, 4.0.20, 4.1.11, 4.2.6.
Is CVE-2026-67404 being exploited?
Not confirmed. CVE-2026-67404 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.20% probability of exploitation in the next 30 days.
How severe is CVE-2026-67404?
CVE-2026-67404 is rated Critical with a CVSS score of 9.2. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-67404?
Yes. A fix has been recorded for CVE-2026-67404. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-67404 affect?
CVE-2026-67404 affects RabbitMQ prior to 3.13.15, RabbitMQ prior to 4.0.20, RabbitMQ prior to 4.1.11, RabbitMQ prior to 4.2.6, and 1 further product or version. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-67404?
Upgrade to fixed versions and ensure cacertfile/OS CA bundle is present
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
MITM attacker can forge JWKS responses causing broker to accept arbitrary JWTs, enabling auth bypass, unauthorized publish/consume, and privilege escalation.
Immediate action required
- affected>= 3.13.0 and < 3.13.15
- affected>= 4.0.0 and < 4.0.20
- affected>= 4.1.0 and < 4.1.11
- affected>= 4.2.0 and < 4.2.6
- affected>= 3.13.0 and < 3.13.15
- affected>= 4.0.0 and < 4.0.20
- affected>= 4.1.0 and < 4.1.11
- affected>= 4.2.0 and < 4.2.6
As published in the CVE Program record, and, for products that ship the affected component, in the advisory named beside them. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.
cisa ssvc
- exploitation
- none
- automatable
- no
- technical impact
- total
Assessed by CISA 29 Sept 2026 (SSVC 2.0.3).
timeline
- 23 Sept 2026Published
- 24 Sept 2026Analysed by vulneraibility.com · same day later
- 29 Sept 2026CISA SSVC assessment: exploitation none · 5 days later
- 29 Sept 2026CVE record last updated · same day later
also known as
- Linkgithub.com /rabbitmq/rabbitmq-server/security/advisories/GHSA-37wx-r6q9-6fhj
- Linkgithub.com /rabbitmq/rabbitmq-server/releases/tag/v4.2.6
sources
- CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
- NVD: CVSS and CPE data
- CISA Vulnrichment (ADP): SSVC decision points
- FIRST EPSS: exploit probability and percentile
- OSV: advisory aliases and downstream package versions
- Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.