RabbitMQ is widely used in enterprise infrastructure; an unauthenticated single-frame exploit can crash the Erlang VM and cause full node/service outages.
CVE-2026-66079
Unauthenticated AMQP1.0 frame triggers RabbitMQ node crash (remote DoS)
do firstUpgrade to a fixed release: 3.13.15, 4.0.20, 4.1.11, 4.2.6.
Is CVE-2026-66079 being exploited?
Not confirmed. CVE-2026-66079 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.32% probability of exploitation in the next 30 days.
How severe is CVE-2026-66079?
CVE-2026-66079 is rated High with a CVSS score of 8.2. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-66079?
Yes. A fix has been recorded for CVE-2026-66079. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-66079 affect?
CVE-2026-66079 affects RabbitMQ < 3.13.15, RabbitMQ < 4.0.20, RabbitMQ < 4.1.11, RabbitMQ < 4.2.6, and 1 further product or version. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-66079?
Upgrade to fixed versions; block/disable AMQP1.0 (port 5672) until patched.
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Unauthenticated remote DoS: a single ~19-byte AMQP 1.0 frame exhausts Erlang VM heap, crashes node and disrupts all tenants/protocols.
Immediate action required
- affected>= 3.13.0 and < 3.13.15
- affected>= 4.0.0 and < 4.0.20
- affected>= 4.1.0 and < 4.1.11
- affected>= 4.2.0 and < 4.2.6
- affected>= 3.13.0 and < 3.13.15
- affected>= 4.0.0 and < 4.0.20
- affected>= 4.1.0 and < 4.1.11
- affected>= 4.2.0 and < 4.2.6
As published in the CVE Program record, and, for products that ship the affected component, in the advisory named beside them. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.
cisa ssvc
- exploitation
- none
- automatable
- yes
- technical impact
- partial
Assessed by CISA 29 Sept 2026 (SSVC 2.0.3).
timeline
- 23 Sept 2026Published
- 24 Sept 2026Analysed by vulneraibility.com · same day later
- 29 Sept 2026CISA SSVC assessment: exploitation none · 5 days later
- 29 Sept 2026CVE record last updated · same day later
also known as
- Linkgithub.com /rabbitmq/rabbitmq-server/security/advisories/GHSA-c66h-hf5j-8jf9
- Linkgithub.com /rabbitmq/rabbitmq-server/releases/tag/v4.2.6
sources
- CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
- NVD: CVSS and CPE data
- CISA Vulnrichment (ADP): SSVC decision points
- FIRST EPSS: exploit probability and percentile
- OSV: advisory aliases and downstream package versions
- Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.