RabbitMQ is widely used messaging infrastructure; this auth bypass lets attackers authenticate to brokers, risking broad disruption and data interception across organizations.
CVE-2026-67231
RabbitMQ trust-store plugin allows TLS client-auth bypass via forged certificates
do firstUpgrade to a fixed release: 3.13.15, 4.0.20, 4.1.11, 4.2.6.
Is CVE-2026-67231 being exploited?
Not confirmed. CVE-2026-67231 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.23% probability of exploitation in the next 30 days.
How severe is CVE-2026-67231?
CVE-2026-67231 is rated Critical with a CVSS score of 9.1. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-67231?
Yes. A fix has been recorded for CVE-2026-67231. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-67231 affect?
CVE-2026-67231 affects RabbitMQ Server prior to 3.13.15, 4.0.20, 4.1.11, 4.2.6, 4.3.0 (trust-store plugin enabled). Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-67231?
Upgrade to the listed fixed versions or disable the trust-store plugin until patched.
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
TLS client-auth bypass: attacker with issuer DN+serial can present a forged self-signed cert to authenticate and access/abuse the broker.
Immediate action required
- affected>= 3.13.0 and < 3.13.15
- affected>= 4.0.0 and < 4.0.20
- affected>= 4.1.0 and < 4.1.11
- affected>= 4.2.0 and < 4.2.6
- affected>= 3.13.0 and < 3.13.15
- affected>= 4.0.0 and < 4.0.20
- affected>= 4.1.0 and < 4.1.11
- affected>= 4.2.0 and < 4.2.6
As published in the CVE Program record, and, for products that ship the affected component, in the advisory named beside them. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.
cisa ssvc
- exploitation
- none
- automatable
- yes
- technical impact
- partial
Assessed by CISA 29 Sept 2026 (SSVC 2.0.3).
timeline
- 23 Sept 2026Published
- 24 Sept 2026Analysed by vulneraibility.com · 1 day later
- 29 Sept 2026CISA SSVC assessment: exploitation none · 4 days later
- 29 Sept 2026CVE record last updated · same day later
also known as
- Linkgithub.com /rabbitmq/rabbitmq-server/security/advisories/GHSA-cw8c-4m83-9c6w
- Linkgithub.com /rabbitmq/rabbitmq-server/releases/tag/v4.2.6
- Linkgithub.com /rabbitmq/rabbitmq-server/releases/tag/v4.3.0
sources
- CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
- NVD: CVSS and CPE data
- CISA Vulnrichment (ADP): SSVC decision points
- FIRST EPSS: exploit probability and percentile
- OSV: advisory aliases and downstream package versions
- Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.