Laravel is a widely used web framework; a high-severity (8.9) CRLF email injection can disrupt notifications and enable interception across many apps.
CVE-2026-48019
CRLF injection in Laravel email validation can tamper with outbound mail.
Can a WAF block it? Partly. The bug can be reached over the network, so generic WAF rules may stop some attacks. Its weakness type is unknown, so we cannot be more precise.
Also consider: patch
Based on the weakness type only; no CVE-specific evidence yet. We check Cloudflare, AWS, Google Cloud Armor and Azure; for Akamai, Imperva, Fastly, F5, ask your vendor.
Is CVE-2026-48019 being exploited?
Not confirmed. CVE-2026-48019 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.51% probability of exploitation in the next 30 days.
How severe is CVE-2026-48019?
CVE-2026-48019 is rated High with a CVSS score of 8.9. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-48019?
Yes. A fix has been recorded for CVE-2026-48019. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-48019 affect?
CVE-2026-48019 affects Laravel <12.60.0, Laravel <13.10.0, Applications using Symfony Mailer/Mime with user-supplied addresses. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-48019?
Upgrade Laravel to >=12.60.0 or >=13.10.0 and validate/sanitize email input.
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Unauthenticated attacker can inject CRLF into user-supplied addresses to modify headers, add recipients, split or intercept outbound emails (e.g., password resets).
Immediate action required
- affected>= 13.0.0 and < 13.10.0
- affected< 12.60.0
As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.