Skip to content
Web

CVE-2026-123564

8.7
High
EPSS 0.34%Patch available

Memory exhaustion via uneval of large sparse arrays in sveltejs devalue (<5.9.3)

exploited
No known exploitation not in CISA KEV as of our last sync
fix
Fixed in 5.9.3
likelihood
EPSS 0.34%top 72% of scored CVEs
Published 8 Nov 2026Analysed here 8 Nov 2026CVSS scored by the publisher (CNA)

do firstUpgrade to a fixed release: 5.9.3.

common questions

Is CVE-2026-123564 being exploited?

Not confirmed. CVE-2026-123564 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.34% probability of exploitation in the next 30 days.

How severe is CVE-2026-123564?

CVE-2026-123564 is rated High with a CVSS score of 8.7. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-123564?

Yes. A fix has been recorded for CVE-2026-123564. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-123564 affect?

CVE-2026-123564 affects sveltejs devalue <5.9.3, Svelte-based web applications, Browsers evaluating uneval output, Node.js runtimes evaluating uneval. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-123564?

Upgrade devalue to >=5.9.3 and sanitize/limit serialized array sizes.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
sveltejs devalue <5.9.3Svelte-based web applicationsBrowsers evaluating uneval outputNode.js runtimes evaluating uneval
impact

Remote memory exhaustion (DoS) by attacker-influenced sparse arrays in uneval-generated code, crashing browsers or Node.js runtimes.

action required

Patch when possible

affected versions
sveltejs devalue
  • affected>= 1.0.0 and < 5.9.3
vendor says fixed in5.9.3

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

timeline

  1. 8 Nov 2026Published
  2. 8 Nov 2026CVE record last updated · same day later
  3. 8 Nov 2026Analysed by vulneraibility.com · 1 day later

also known as

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
2 references in the CVE record: 2 advisories
  • Advisorygithub.com /sveltejs/devalue/security/advisories/GHSA-wf3x-273g-mvxv
  • Advisoryvulncheck.com /advisories/sveltejs-devalue-before-5.9.3-memory-exhaustion-via-uneval-sparse-ar

sources

  • CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
  • NVD: CVSS and CPE data
  • FIRST EPSS: exploit probability and percentile
  • OSV: advisory aliases and downstream package versions
  • Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved