WordPress is widely deployed; unauthenticated RCE in core can enable mass site/server compromise and is news-worthy across IT teams.
CVE-2026-119977
Unauthenticated RCE in WordPress core via predictable staging paths during upgrades.
Is CVE-2026-119977 being exploited?
Not confirmed. CVE-2026-119977 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.60% probability of exploitation in the next 30 days.
How severe is CVE-2026-119977?
CVE-2026-119977 is rated High with a CVSS score of 8.1. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-119977?
Yes. A fix has been recorded for CVE-2026-119977. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-119977 affect?
CVE-2026-119977 affects WordPress Core 4.7 - 7.1.3, Self-hosted WordPress sites performing full-package core upgrades. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-119977?
Upgrade to WordPress 7.1.4 immediately; restrict upgrade path access and scan for compromise.
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Unauthenticated remote code execution during full-package upgrades, enabling server takeover, webshells, data theft, or lateral pivoting.
Immediate action required
- affected>= 4.7.0 and <= 4.7.38
- affected>= 4.8.0 and <= 4.8.33
- affected>= 4.9.0 and <= 4.9.34
- affected>= 5.0.0 and <= 5.0.30
- affected>= 5.1.0 and <= 5.1.27
- affected>= 5.2.0 and <= 5.2.29
- affected>= 5.3.0 and <= 5.3.26
- affected>= 5.4.0 and <= 5.4.24
- affected>= 5.5.0 and <= 5.5.23
- affected>= 5.6.0 and <= 5.6.22
- affected>= 5.7.0 and <= 5.7.20
- affected>= 5.8.0 and <= 5.8.18
- affected>= 5.9.0 and <= 5.9.19
- affected>= 6.0.0 and <= 6.0.17
- affected>= 6.1.0 and <= 6.1.15
- affected>= 6.2.0 and <= 6.2.14
- affected>= 6.3.0 and <= 6.3.13
- affected>= 6.4.0 and <= 6.4.13
- affected>= 6.5.0 and <= 6.5.13
- affected>= 6.6.0 and <= 6.6.10
- affected>= 6.7.0 and <= 6.7.10
- affected>= 6.8.0 and <= 6.8.11
- affected>= 6.9.0 and <= 6.9.10
- affected>= 7.0.0 and <= 7.0.7
- affected>= 7.1.0 and <= 7.1.3
As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.