Skip to content
major vulnerability· requires attention

node-opcua is an OPC UA library used in OT/ICS stacks; flaw lets anonymous clients bypass permissions to write/invoke, risking disruption of industrial processes.

OT/ICS

CVE-2026-95860

9.1
Critical
EPSS 0.60%Patch available

Auth bypass in node-opcua allows anonymous write/call on OPC UA servers.

exploited
No known exploitation not in CISA KEV as of our last sync
fix
Patch available see the advisory in the references
likelihood
EPSS 0.60%top 52% of scored CVEs
Published 3 Nov 2026Analysed here 5 Nov 2026CVSS scored by the publisher (CNA)
common questions

Is CVE-2026-95860 being exploited?

Not confirmed. CVE-2026-95860 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.60% probability of exploitation in the next 30 days.

How severe is CVE-2026-95860?

CVE-2026-95860 is rated Critical with a CVSS score of 9.1. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-95860?

Yes. A fix has been recorded for CVE-2026-95860. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-95860 affect?

CVE-2026-95860 affects node-opcua >=2.42.0 and <2.180.0, OPC UA servers built with node-opcua. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-95860?

Upgrade node-opcua to >=2.180.0; restrict network access to OPC UA endpoints and audit logs.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
node-opcua >=2.42.0 and <2.180.0OPC UA servers built with node-opcua
impact

Anonymous network attacker can bypass namespace RolePermissions to write variables and invoke methods, altering OT process state and enabling disruptive actions.

action required

Immediate action required

affected versions
node-opcua
  • affected>= 2.42.0 and < 2.180.0

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

timeline

  1. 3 Nov 2026Published
  2. 3 Nov 2026CVE record last updated · same day later
  3. 5 Nov 2026Analysed by vulneraibility.com · 2 days later

also known as

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
4 references in the CVE record: 4 links
  • Linkgithub.com /node-opcua/node-opcua/security/advisories/GHSA-xggf-m53x-jc3f
  • Linkgithub.com /node-opcua/node-opcua/pull/1580
  • Linkgithub.com /node-opcua/node-opcua/commit/0261e873900800983c622e01120f484dc6063698
  • Linkgithub.com /node-opcua/node-opcua/releases/tag/v2.180.0

sources

  • CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
  • NVD: CVSS and CPE data
  • FIRST EPSS: exploit probability and percentile
  • OSV: advisory aliases and downstream package versions
  • Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved