Skip to content
major vulnerability· requires attention

RCE in ISC BIND, a widely deployed DNS server; exploitation could disrupt DNS infrastructure and many organizations.

Infrastructure

CVE-2026-94300

8.1
High
EPSS 0.95%Patch availableOct 24, 2026

Replay of GSS-TSIG UDP messages in BIND can cause memory corruption and possible RCE.

common questions

Is CVE-2026-94300 being exploited?

Not confirmed. CVE-2026-94300 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.95% probability of exploitation in the next 30 days.

How severe is CVE-2026-94300?

CVE-2026-94300 is rated High with a CVSS score of 8.1. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-94300?

Yes. A fix has been recorded for CVE-2026-94300. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-94300 affect?

CVE-2026-94300 affects ISC BIND 9.11.0 - 9.18.50, ISC BIND 9.20.0 - 9.20.29, ISC BIND 9.21.0 - 9.21.26, ISC BIND 9.11.3-S1 - 9.18.50-S1, and 1 further product or version. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-94300?

Upgrade to fixed BIND versions (9.20.30 or 9.21.27) immediately or apply vendor mitigations.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
ISC BIND 9.11.0 - 9.18.50ISC BIND 9.20.0 - 9.20.29ISC BIND 9.21.0 - 9.21.26ISC BIND 9.11.3-S1 - 9.18.50-S1ISC BIND 9.20.9-S1 - 9.20.29-S1
impact

Replayed signed UDP messages can trigger memory corruption in named, enabling remote code execution via attacker-controlled queries.

action required

Immediate action required

affected versions
ISC BIND 9
  • affected>= 9.11.0 and <= 9.18.50
  • affected>= 9.20.0 and <= 9.20.29
  • affected>= 9.21.0 and <= 9.21.26
  • affected>= 9.11.3-S1 and <= 9.18.50-S1
  • affected>= 9.20.9-S1 and <= 9.20.29-S1

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved