Skip to content
major vulnerability· requires attention

Auth-to-RCE in a widely deployed team-chat server (Mattermost) allowing plugin replacement and server code execution; high-impact for orgs using Mattermost.

Applications

CVE-2026-93851

8.0
High
EPSS n/aOct 31, 2026

Auth-post can trick admin to replace plugin, enabling server RCE.

common questions

Is CVE-2026-93851 being exploited?

Not confirmed. CVE-2026-93851 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked.

How severe is CVE-2026-93851?

CVE-2026-93851 is rated High with a CVSS score of 8.0. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-93851?

Not known from our data. No patch reference has been recorded for CVE-2026-93851, which is not the same as no patch existing — a fix may have shipped without a tagged reference, or after this record was written. The vendor advisory is the only authority on whether a fix exists, and mitigations may be available regardless.

What does CVE-2026-93851 affect?

CVE-2026-93851 affects Mattermost 11.7.0–11.7.10, Mattermost 11.8.0–11.8.5, Mattermost 11.9.0–11.9.1. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-93851?

Apply vendor patch ASAP; if unavailable disable Agents plugin and restrict posting.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Mattermost 11.7.0–11.7.10Mattermost 11.8.0–11.8.5Mattermost 11.9.0–11.9.1
impact

Authenticated user can cause an admin's browser to trigger an API request that replaces an installed plugin, resulting in remote code execution on the Mattermost server.

action required

Immediate action required

affected versions
Mattermost
  • affected>= 11.9.0 and <= 11.9.1
  • affected>= 11.8.0 and <= 11.8.5
  • affected>= 11.7.0 and <= 11.7.10
vendor says fixed in11.10.0, 11.9.2, 11.8.6, 11.7.11

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved