# CVE-2026-92946

vm2 sandbox RCE allows escaped code to run host OS commands

- Page: https://www.vulneraibility.com/cve/CVE-2026-92946
- CVSS: 10.0
- Known exploited: not in CISA KEV as of our last sync
- EPSS: 0.78% (percentile 55.8)
- CISA SSVC: exploitation none, automatable yes, technical impact total (assessed 2026-09-17)
- Weakness: CWE-913
- Also known as: GHSA-j3hm-6rg5-mchv
- Published: 2026-09-17

## Affected versions

- patriksimek vm2: affected < 3.11.7; fixed in 3.11.7

A version outside these ranges is not a statement that it is unaffected.

## Impact

Remote code execution: sandboxed code can require vm2, instantiate an unrestricted NodeVM and run arbitrary host commands via child_process.

## Action

Immediate action required

## Recommendation

Upgrade vm2 to >=3.11.7 or disable require.external; audit sandboxes immediately.

## References

- [advisory] https://github.com/patriksimek/vm2/security/advisories/GHSA-j3hm-6rg5-mchv
- [advisory] https://www.vulncheck.com/advisories/vm2-before-3.11.7-remote-code-execution-via-require-external

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
