Skip to content
major vulnerability· requires attention

vm2 is widely used to sandbox untrusted JS in many Node.js apps; a gadget allows full host command execution (RCE), risking broad compromise of services that embed it.

Applications

CVE-2026-92946

10.0
Critical
EPSS 0.78%Patch available

vm2 sandbox RCE allows escaped code to run host OS commands

exploited
No known exploitation not in CISA KEV as of our last sync
fix
Fixed in 3.11.7
likelihood
EPSS 0.78%top 45% of scored CVEs
Published 17 Sept 2026Analysed here 19 Sept 2026CVSS scored by the publisher (CNA)

do firstUpgrade to a fixed release: 3.11.7.

common questions

Is CVE-2026-92946 being exploited?

Not confirmed. CVE-2026-92946 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.78% probability of exploitation in the next 30 days.

How severe is CVE-2026-92946?

CVE-2026-92946 is rated Critical with a CVSS score of 10.0. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-92946?

Yes. A fix has been recorded for CVE-2026-92946. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-92946 affect?

CVE-2026-92946 affects vm2 < 3.11.7, Node.js applications using vm2 with require.external enabled, web services, SaaS, online code sandboxes, CI systems. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-92946?

Upgrade vm2 to >=3.11.7 or disable require.external; audit sandboxes immediately.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
vm2 < 3.11.7Node.js applications using vm2 with require.external enabledweb services, SaaS, online code sandboxes, CI systems
impact

Remote code execution: sandboxed code can require vm2, instantiate an unrestricted NodeVM and run arbitrary host commands via child_process.

action required

Immediate action required

affected versions
patriksimek vm2
  • affected< 3.11.7
vendor says fixed in3.11.7

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

cisa ssvc

exploitation
none
automatable
yes
technical impact
total

Assessed by CISA 17 Sept 2026 (SSVC 2.0.3).

timeline

  1. 17 Sept 2026Published
  2. 17 Sept 2026CISA SSVC assessment: exploitation none · same day later
  3. 17 Sept 2026CVE record last updated · same day later
  4. 19 Sept 2026Analysed by vulneraibility.com · 1 day later

also known as

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
2 references in the CVE record: 2 advisories
  • Advisorygithub.com /patriksimek/vm2/security/advisories/GHSA-j3hm-6rg5-mchv
  • Advisoryvulncheck.com /advisories/vm2-before-3.11.7-remote-code-execution-via-require-external

sources

  • CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
  • NVD: CVSS and CPE data
  • CISA Vulnrichment (ADP): SSVC decision points
  • FIRST EPSS: exploit probability and percentile
  • OSV: advisory aliases and downstream package versions
  • Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved