# CVE-2026-92935

vm2 sandbox escape enabling RCE via array-shaped require

- Page: https://www.vulneraibility.com/cve/CVE-2026-92935
- CVSS: 9.5
- Known exploited: not in CISA KEV as of our last sync
- EPSS: 0.64% (percentile 50.5)
- Unvetted proof-of-concept code on GitHub: 1 GitHub proof of concept (first 2026-10-23)
- CISA SSVC: exploitation none, automatable no, technical impact total (assessed 2026-09-17)
- Weakness: CWE-913
- Also known as: GHSA-8hr7-r645-pc6w
- Published: 2026-09-17

## Affected versions

- patriksimek vm2: affected >= 3.11.4 and < 3.11.7; fixed in 3.11.7

A version outside these ranges is not a statement that it is unaffected.

## Impact

Sandbox escape to arbitrary host RCE: attacker can spawn inner NodeVM with builtin allowlist (e.g., child_process) and execute commands as the host Node.js process.

## Action

Immediate action required

## Recommendation

Upgrade to vm2 v3.11.7+; disable nesting or sanitize require; audit and rotate credentials if exposed

## References

- [advisory] https://github.com/patriksimek/vm2/security/advisories/GHSA-8hr7-r645-pc6w
- [patch] https://github.com/patriksimek/vm2/commit/54b54b74a382577f0bcd0538c5bf99acdcd7f53b
- [advisory] https://www.vulncheck.com/advisories/vm2-nodevm-remote-code-execution-via-array-shaped-require

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
