vm2 is a widely used Node.js sandbox library; this vulnerability allows sandbox escape and host RCE across many apps and services, posing broad, high-impact risk.
CVE-2026-92935
vm2 sandbox escape enabling RCE via array-shaped require
do firstUpgrade to a fixed release: 3.11.7.
Is CVE-2026-92935 being exploited?
Not confirmed. CVE-2026-92935 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.64% probability of exploitation in the next 30 days.
How severe is CVE-2026-92935?
CVE-2026-92935 is rated Critical with a CVSS score of 9.5. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-92935?
Yes. A fix has been recorded for CVE-2026-92935. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-92935 affect?
CVE-2026-92935 affects vm2 v3.11.4 - v3.11.6, NodeVM in vm2-based Node.js applications, Host Node.js process running vm2. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-92935?
Upgrade to vm2 v3.11.7+; disable nesting or sanitize require; audit and rotate credentials if exposed
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Sandbox escape to arbitrary host RCE: attacker can spawn inner NodeVM with builtin allowlist (e.g., child_process) and execute commands as the host Node.js process.
Immediate action required
- affected>= 3.11.4 and < 3.11.7
As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.
public exploits
Unvetted proof-of-concept code on GitHub: 1 GitHub proof of concept
Listed so you can judge urgency, not as a recommendation to run anything. GitHub “proofs of concept” are unvetted: some are fake or carry malware. Exploit-DB marks the entries its staff verified.
cisa ssvc
- exploitation
- none
- automatable
- no
- technical impact
- total
Assessed by CISA 17 Sept 2026 (SSVC 2.0.3).
timeline
- 17 Sept 2026Published
- 17 Sept 2026CISA SSVC assessment: exploitation none · same day later
- 17 Sept 2026CVE record last updated · same day later
- 19 Sept 2026Analysed by vulneraibility.com · 1 day later
- 23 Oct 2026First proof-of-concept repository on GitHub (unvetted) · 34 days later
also known as
- Advisorygithub.com /patriksimek/vm2/security/advisories/GHSA-8hr7-r645-pc6w
- Advisoryvulncheck.com /advisories/vm2-nodevm-remote-code-execution-via-array-shaped-require
- Patchgithub.com /patriksimek/vm2/commit/54b54b74a382577f0bcd0538c5bf99acdcd7f53b
sources
- CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
- NVD: CVSS and CPE data
- CISA Vulnrichment (ADP): SSVC decision points
- FIRST EPSS: exploit probability and percentile
- PoC-in-GitHub: GitHub repositories that claim a proof of concept
- OSV: advisory aliases and downstream package versions
- Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.