Skip to content
major vulnerability· requires attention

Progress WS_FTP is widely used enterprise file-transfer software; this flaw enables privilege escalation and arbitrary command execution leading to full server compromise.

Applications

CVE-2026-90863

9.1
Critical
EPSS n/aPatch availableOct 30, 2026

Auth bypass in WS_FTP admin allows delegated admin to execute arbitrary commands.

common questions

Is CVE-2026-90863 being exploited?

Not confirmed. CVE-2026-90863 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked.

How severe is CVE-2026-90863?

CVE-2026-90863 is rated Critical with a CVSS score of 9.1. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-90863?

Yes. A fix has been recorded for CVE-2026-90863. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-90863 affect?

CVE-2026-90863 affects Progress WS_FTP Server (Windows) versions prior to 2024.0.7, Progress WS_FTP Server (Windows) versions prior to 2025.0.4. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-90863?

Immediately upgrade to 2024.0.7 or 2025.0.4 and restrict admin access until patched

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Progress WS_FTP Server (Windows) versions prior to 2024.0.7Progress WS_FTP Server (Windows) versions prior to 2025.0.4
impact

Delegated Host Admin can bypass authorization to run arbitrary commands with elevated privileges, enabling full compromise of the server.

action required

Immediate action required

affected versions
Progress Software WS_FTP Server
  • affected< 2024.0.7
  • affected< 2025.0.4

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved