RCE in widely used OpenSearch SQL plugin allowing authenticated users with minimal read/search privileges to execute code; affects multiple release lines and requires immediate org-wide attention.
CVE-2026-63393
Authenticated RCE in OpenSearch SQL via crafted cursor parameter
Is CVE-2026-63393 being exploited?
Not confirmed. CVE-2026-63393 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked.
How severe is CVE-2026-63393?
CVE-2026-63393 is rated High with a CVSS score of 8.7. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-63393?
Yes. A fix has been recorded for CVE-2026-63393. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-63393 affect?
CVE-2026-63393 affects OpenSearch SQL plugin 2.8.0.0 <= v < 2.19.6.0, OpenSearch SQL plugin 3.x < 3.7.0.0, OpenSearch deployments exposing /plugins/sql endpoint. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-63393?
Upgrade to 2.19.6.0 or 3.7.0.0; restrict/limit SQL endpoint access and rotate creds
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Authenticated remote code execution via crafted 'cursor' to /plugins/sql; attacker with read/search can run arbitrary code on the server.
Immediate action required
- affected>= 2.8.0.0 and < 2.19.6.0
- affected>= 3.0.0.0-alpha1 and < 3.7.0.0
As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.