Skip to content
major vulnerability· requires attention

Widely used GitLab CE/EE; account takeover of LDAP-backed accounts can expose repos, CI, and org secrets — significant impact for many enterprises.

Applications

CVE-2026-15723

8.2
High
EPSS 0.42%Patch availableOct 24, 2026

Authenticated user can takeover LDAP-backed GitLab accounts when SAML+LDAP auto-link enabled

common questions

Is CVE-2026-15723 being exploited?

Not confirmed. CVE-2026-15723 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.42% probability of exploitation in the next 30 days.

How severe is CVE-2026-15723?

CVE-2026-15723 is rated High with a CVSS score of 8.2. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-15723?

Yes. A fix has been recorded for CVE-2026-15723. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-15723 affect?

CVE-2026-15723 affects GitLab CE/EE versions from 10.1 before 19.3.6, GitLab 19.4 before 19.4.3, GitLab 19.5 before 19.5.1. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-15723?

Upgrade to fixed versions (>=19.3.6,19.4.3,19.5.1) or disable SAML/LDAP auto-linking

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
GitLab CE/EE versions from 10.1 before 19.3.6GitLab 19.4 before 19.4.3GitLab 19.5 before 19.5.1
impact

Authenticated attacker can hijack LDAP-backed GitLab accounts via OmniAuth SAML+LDAP auto-link, gaining repository, CI and potential admin access.

action required

Immediate action required

affected versions
GitLab GitLab
  • affected>= 10.1 and < 19.3.6
  • affected>= 19.4 and < 19.4.3
  • affected>= 19.5 and < 19.5.1

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved