Skip to content
Applications

CVE-2026-124078

8.7
High
EPSS n/aPatch available

Crafted binary plist triggers exponential recursion in plist.js, crashing Node.js processes.

exploited
No known exploitation not in CISA KEV as of our last sync
fix
Patch available see the advisory in the references
likelihood
No EPSS score yet
Published 6 Nov 2026Analysed here 7 Nov 2026CVSS scored by the publisher (CNA)
common questions

Is CVE-2026-124078 being exploited?

Not confirmed. CVE-2026-124078 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked.

How severe is CVE-2026-124078?

CVE-2026-124078 is rated High with a CVSS score of 8.7. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-124078?

Yes. A fix has been recorded for CVE-2026-124078. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-124078 affect?

CVE-2026-124078 affects plist (npm package) < 5.0.1, Node.js applications using plist.js binary parser, Services parsing untrusted binary plist files. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-124078?

Upgrade to plist 5.0.1; block or validate untrusted binary plist inputs.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
plist (npm package) < 5.0.1Node.js applications using plist.js binary parserServices parsing untrusted binary plist files
impact

Unauthenticated remote Denial of Service: crafted binary plist causes exponential resolution, OOM and crash of Node.js applications.

action required

Immediate action required

affected versions
TooTallNate plist.js
  • affected< 5.0.1

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

timeline

  1. 6 Nov 2026Published
  2. 6 Nov 2026CVE record last updated · same day later
  3. 7 Nov 2026Analysed by vulneraibility.com · same day later
how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
3 references in the CVE record: 1 advisory, 1 patch, 1 link
  • Advisoryvulncheck.com /advisories/plist-js-before-uncontrolled-resource-consumption-via-binary-parser
  • Patchgithub.com /TooTallNate/plist.js/releases/tag/plist%405.0.1
  • Linkgithub.com /TooTallNate/plist.js/commit/ac871e67aa0b0440da50bf40d58c6deddce9d8c1

sources

  • CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
  • NVD: CVSS and CPE data
  • FIRST EPSS: exploit probability and percentile
  • Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved