Skip to content
major vulnerability· requires attention

Affects widely used Apache ZooKeeper; can cause persistent ensemble-wide outages and data loss, impacting many distributed systems and services.

Infrastructure

CVE-2026-115448

8.7
High
EPSS n/aPatch available

Deeply nested znodes cause persistent JVM stack-exhaustion DoS in Apache ZooKeeper

exploited
No known exploitation not in CISA KEV as of our last sync
fix
Patch available see the advisory in the references
likelihood
No EPSS score yet
Published 4 Nov 2026Analysed here 5 Nov 2026CVSS scored by the publisher (CNA)
common questions

Is CVE-2026-115448 being exploited?

Not confirmed. CVE-2026-115448 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked.

How severe is CVE-2026-115448?

CVE-2026-115448 is rated High with a CVSS score of 8.7. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-115448?

Yes. A fix has been recorded for CVE-2026-115448. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-115448 affect?

CVE-2026-115448 affects Apache ZooKeeper 3.8.0-3.8.7, Apache ZooKeeper 3.9.0-3.9.6, ZooKeeper ensembles. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-115448?

Upgrade to 3.8.8 or 3.9.7; restrict znode creation via ACLs/authentication

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Apache ZooKeeper 3.8.0-3.8.7Apache ZooKeeper 3.9.0-3.9.6ZooKeeper ensembles
impact

Attacker with znode-create permission can craft nested znodes to exhaust JVM stack during snapshots, causing persistent DoS across restarts, ensemble spread, and possible data loss.

action required

Immediate action required

affected versions
Apache Software Foundation Apache ZooKeeper
  • affected>= 3.9.0 and <= 3.9.7
  • affected>= 3.8.0 and <= 3.8.8

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

cisa ssvc

exploitation
none
automatable
yes
technical impact
partial

Assessed by CISA 4 Nov 2026 (SSVC 2.0.3).

timeline

  1. 4 Nov 2026Published
  2. 4 Nov 2026CISA SSVC assessment: exploitation none · same day later
  3. 4 Nov 2026CVE record last updated · same day later
  4. 5 Nov 2026Analysed by vulneraibility.com · 1 day later
how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
2 references in the CVE record: 1 advisory, 1 link

sources

  • CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
  • NVD: CVSS and CPE data
  • CISA Vulnrichment (ADP): SSVC decision points
  • FIRST EPSS: exploit probability and percentile
  • Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved