Pillow is a widely used Python imaging library; this RCE via Ghostscript argument injection can affect many web apps and services that process EPS files, creating broad operational risk.
CVE-2026-112900
Pillow EPS Ghostscript argument injection can lead to remote code execution.
Is CVE-2026-112900 being exploited?
Not confirmed. CVE-2026-112900 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 1.1% probability of exploitation in the next 30 days.
How severe is CVE-2026-112900?
CVE-2026-112900 is rated Critical with a CVSS score of 9.2. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.
Is there a patch for CVE-2026-112900?
Yes. A fix has been recorded for CVE-2026-112900. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.
What does CVE-2026-112900 affect?
CVE-2026-112900 affects Pillow 2.6.0 through 12.x (v13.0.0 fixes). Confirm the exact affected versions against the vendor advisory before deciding you are exposed.
What should I do about CVE-2026-112900?
Upgrade to Pillow 13.0.0+ and sanitize EPS filenames; restrict untrusted file processing.
Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.
Remote code execution via Ghostscript argument/@file injection when processing attacker-controlled EPS filenames.
Immediate action required
- affected>= 2.6.0 and < 13.0.0
As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.