Skip to content
major vulnerability· requires attention

Very high-severity (CVSS 10.0) auth bypass in widely used Canonical LXD allowing full cluster and VM takeover; impacts cloud/infra and is organization-disrupting.

Cloud

CVE-2026-112816

10.0
Critical
EPSS n/aPatch availableOct 31, 2026

TLS client-cert validation bypass in Canonical LXD allows full cluster and VM takeover.

common questions

Is CVE-2026-112816 being exploited?

Not confirmed. CVE-2026-112816 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked.

How severe is CVE-2026-112816?

CVE-2026-112816 is rated Critical with a CVSS score of 10.0. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-112816?

Yes. A fix has been recorded for CVE-2026-112816. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-112816 affect?

CVE-2026-112816 affects Canonical LXD 4.0.14, Canonical LXD 5.0.10, Canonical LXD 5.21.8, Canonical LXD 6.9, and 1 further product or version. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-112816?

Upgrade to fixed LXD releases (4.0.15,5.0.11,5.21.9,6.10.1) and restrict management access.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Canonical LXD 4.0.14Canonical LXD 5.0.10Canonical LXD 5.21.8Canonical LXD 6.9LXD clusters / MicroCloud deployments using affected versions
impact

Unauthenticated attacker can bypass HTTPS client cert validation, impersonate any trusted client, and gain full cluster admin access and control of hosted VMs.

action required

Immediate action required

affected versions
Canonical LXD
  • affected>= 4.0.14 and < 4.0.15
  • affected>= 5.0.10 and < 5.0.11
  • affected>= 5.21.8 and < 5.21.9
  • affected>= 6.9.0 and < 6.10.1

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved