Skip to content
major vulnerability· requires attention

High-impact remote code execution and IAM credential theft affecting widely used AWS SageMaker SDK; broad cloud/ML risk requiring org-wide attention.

Cloud

CVE-2026-112408

9.4
Critical
EPSS 0.74%Patch availableOct 24, 2026

Predictable S3 bucket flaw in SageMaker SDK allows RCE and IAM credential theft

common questions

Is CVE-2026-112408 being exploited?

Not confirmed. CVE-2026-112408 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.74% probability of exploitation in the next 30 days.

How severe is CVE-2026-112408?

CVE-2026-112408 is rated Critical with a CVSS score of 9.4. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-112408?

Yes. A fix has been recorded for CVE-2026-112408. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-112408 affect?

CVE-2026-112408 affects Amazon SageMaker Python SDK v3 < 3.10.0, Amazon SageMaker Python SDK v2 < 2.257.3, SageMaker execution environments, S3 buckets used by the SDK. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-112408?

Upgrade to sagemaker v3.10.0 or v2.257.3; rotate exposed IAM keys; audit S3 buckets and SageMaker jobs.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Amazon SageMaker Python SDK v3 < 3.10.0Amazon SageMaker Python SDK v2 < 2.257.3SageMaker execution environmentsS3 buckets used by the SDK
impact

Remote code execution in SageMaker execution environments and theft of IAM credentials by pre-creating a predictably named S3 bucket used by the SDK.

action required

Immediate action required

affected versions
AWS Amazon SageMaker Python SDK
  • affected< 2.257.3
  • affected>= 3.0.0 and < 3.10.0

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved