Skip to content
major vulnerability· requires attention

Unauthenticated RCE in Apache Traffic Server's magick plugin with CVSS 10.0 affecting widely-used web caching/reverse-proxy software; high-impact infrastructure risk requiring org-wide notice.

Infrastructure

CVE-2026-111813

10.0
Critical
EPSS 0.49%Patch availableOct 24, 2026

Unauthenticated argument injection in ATS magick plugin enabling RCE.

common questions

Is CVE-2026-111813 being exploited?

Not confirmed. CVE-2026-111813 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked. EPSS currently estimates a 0.49% probability of exploitation in the next 30 days.

How severe is CVE-2026-111813?

CVE-2026-111813 is rated Critical with a CVSS score of 10.0. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-111813?

Yes. A fix has been recorded for CVE-2026-111813. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-111813 affect?

CVE-2026-111813 affects Apache Traffic Server magick plugin (default unsigned), Apache Traffic Server 8.0.1-8.1.11, Apache Traffic Server 9.0.0-9.2.15, Apache Traffic Server 10.0.0-10.1.4, and 2 further products or versions. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-111813?

Upgrade to 9.2.16, 10.1.5, or 10.2.1 immediately; disable magick plugin until patched.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
Apache Traffic Server magick plugin (default unsigned)Apache Traffic Server 8.0.1-8.1.11Apache Traffic Server 9.0.0-9.2.15Apache Traffic Server 10.0.0-10.1.4Apache Traffic Server 10.2.0ImageMagick (invoked by plugin)
impact

Unauthenticated attacker can control ImageMagick convert args via ATS magick plugin, enabling remote code execution and file access.

action required

Immediate action required

affected versions
Apache Software Foundation Apache Traffic Server
  • affected>= 8.0.1 and <= 8.1.11
  • affected>= 9.0.0 and <= 9.2.15
  • affected>= 10.0.0 and <= 10.1.4
  • affected10.2.0

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved