Skip to content
major vulnerability· requires attention

musl libc is a widely used C library (Alpine, containers, embedded). A heap OOB/overflow in libc can cause crashes or code execution across many deployments.

Systems

CVE-2026-107891

8.1
High
EPSS n/aPatch available

Integer overflows in musl regcomp cause heap OOB writes

exploited
No known exploitation not in CISA KEV as of our last sync
fix
Patch available see the advisory in the references
likelihood
No EPSS score yet
Published 5 Nov 2026Analysed here 6 Nov 2026CVSS scored by the publisher (CNA)
common questions

Is CVE-2026-107891 being exploited?

Not confirmed. CVE-2026-107891 does not appear in CISA's Known Exploited Vulnerabilities catalog, which records only exploitation that has been observed and reported publicly. That is evidence of absence of a report, not evidence the flaw is unattacked.

How severe is CVE-2026-107891?

CVE-2026-107891 is rated High with a CVSS score of 8.1. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2026-107891?

Yes. A fix has been recorded for CVE-2026-107891. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2026-107891 affect?

CVE-2026-107891 affects musl libc < 1.2.7, Linux distros using musl (e.g., Alpine), Container images based on musl, Embedded systems using musl. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

What should I do about CVE-2026-107891?

Upgrade to musl 1.2.7, rebuild and redeploy affected binaries/images

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
musl libc < 1.2.7Linux distros using musl (e.g., Alpine)Container images based on muslEmbedded systems using musl
impact

Integer overflows in regcomp lead to incorrect allocations and heap out-of-bounds writes, enabling crashes or potential arbitrary code execution if attacker-controlled regex is compiled.

action required

Patch when possible

affected versions
musl -libc musl
  • affected>= 0.5.0 and < 1.2.7

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

timeline

  1. 5 Nov 2026Published
  2. 5 Nov 2026CVE record last updated · same day later
  3. 6 Nov 2026Analysed by vulneraibility.com · 1 day later
how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
4 references in the CVE record: 4 links

sources

  • CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
  • NVD: CVSS and CPE data
  • FIRST EPSS: exploit probability and percentile
  • Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved