# CVE-2025-58360

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

- Page: https://www.vulneraibility.com/cve/CVE-2025-58360
- CVSS: 8.2
- Known exploited: yes, in CISA KEV since 2025-12-11; CISA due date 2026-01-01
- EPSS: 61.17%
- Unvetted proof-of-concept code on GitHub: 1 Metasploit module · 6 GitHub proofs of concept · 1 Nuclei template (first 2025-11-27)
- CISA SSVC: exploitation active, automatable yes, technical impact partial (assessed 2025-12-12)
- Weakness: CWE-611
- Also known as: GHSA-fjf5-xgmq-5525
- Published: 2025-11-25

## Affected versions

- geoserver: affected >= 2.26.0 and < 2.26.2; < 2.25.6

A version outside these ranges is not a statement that it is unaffected.

## References

- [other] https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525
- [other] https://osgeo-org.atlassian.net/browse/GEOS-11682
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-58360

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
