# CVE-2025-57819

FreePBX is an open-source web-based graphical user interface. FreePBX 15, 16, and 17 endpoints are vulnerable due to insufficiently sanitized user-supplied data allowing unauthenticated access to FreePBX Administrator leading to arbitrary database manipulation and remote code execution. This issue has been patched in endpoint versions 15.0.66, 16.0.89, and 17.0.3.

- Page: https://www.vulneraibility.com/cve/CVE-2025-57819
- CVSS: 9.8
- Known exploited: yes, in CISA KEV since 2025-08-29; CISA due date 2025-09-19
- EPSS: 95.21%
- Public exploit code: 1 on Exploit-DB · 1 Metasploit module · 26 GitHub proofs of concept · 1 Nuclei template (first 2025-08-28)
- CISA SSVC: exploitation active, automatable yes, technical impact total (assessed 2025-08-29)
- Weakness: CWE-89, CWE-288
- Also known as: GHSA-m42g-xg4c-5f3h
- Published: 2025-08-28

## Affected versions

- FreePBX endpoint: affected < 15.0.66; < 16.0.89; < 17.0.3

A version outside these ranges is not a statement that it is unaffected.

## References

- [other] https://github.com/FreePBX/security-reporting/security/advisories/GHSA-m42g-xg4c-5f3h
- [other] https://community.freepbx.org/t/security-advisory-please-lock-down-your-administrator-access/107203
- [exploit] https://github.com/watchtowrlabs/watchTowr-vs-FreePBX-CVE-2025-57819
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-57819

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
