# CVE-2025-32432

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.

- Page: https://www.vulneraibility.com/cve/CVE-2025-32432
- CVSS: 10.0
- Known exploited: yes, in CISA KEV since 2026-03-20; CISA due date 2026-04-03
- EPSS: 99.79%
- Public exploit code: 1 on Exploit-DB · 1 Metasploit module · 15 GitHub proofs of concept · 1 Nuclei template (first 2025-04-26)
- CISA SSVC: exploitation active, automatable yes, technical impact total (assessed 2025-04-28)
- Weakness: CWE-94
- Also known as: GHSA-f3gw-9ww9-jmc3
- Published: 2025-04-25

## Affected versions

- craftcms cms: affected >= 3.0.0-RC1 and < 3.9.15; >= 4.0.0-RC1 and < 4.14.15; >= 5.0.0-RC1 and < 5.6.17

A version outside these ranges is not a statement that it is unaffected.

## References

- [other] https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3
- [other] https://github.com/craftcms/cms/commit/e1c85441fa47eeb7c688c2053f25419bc0547b47
- [other] https://github.com/craftcms/cms/blob/3.x/CHANGELOG.md#3915---2025-04-10-critical
- [other] https://github.com/craftcms/cms/blob/4.x/CHANGELOG.md#41415---2025-04-10-critical
- [other] https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5617---2025-04-10-critical
- [exploit] https://sensepost.com/blog/2025/investigating-an-in-the-wild-campaign-using-rce-in-craftcms/
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-32432

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
