# CVE-2025-31125

Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. This vulnerability is fixed in 6.2.4, 6.1.3, 6.0.13, 5.4.16, and 4.5.11.

- Page: https://www.vulneraibility.com/cve/CVE-2025-31125
- CVSS: 5.3
- Known exploited: yes, in CISA KEV since 2026-01-22; CISA due date 2026-02-12
- EPSS: 74.94%
- Unvetted proof-of-concept code on GitHub: 4 GitHub proofs of concept · 1 Nuclei template (first 2025-04-01)
- CISA SSVC: exploitation active, automatable no, technical impact total (assessed 2026-01-23)
- Weakness: CWE-200, CWE-284
- Also known as: GHSA-4r4m-qw57-chr8
- Published: 2025-03-31

## Affected versions

- vitejs vite: affected >= 6.2.0 and < 6.2.4; >= 6.1.0 and < 6.1.3; >= 6.0.0 and < 6.0.13; >= 5.0.0 and < 5.4.16; < 4.5.11

A version outside these ranges is not a statement that it is unaffected.

## References

- [other] https://github.com/vitejs/vite/security/advisories/GHSA-4r4m-qw57-chr8
- [other] https://github.com/vitejs/vite/commit/59673137c45ac2bcfad1170d954347c1a17ab949
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-31125

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
