# CVE-2025-24813

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

- Page: https://www.vulneraibility.com/cve/CVE-2025-24813
- CVSS: 9.8
- Known exploited: yes, in CISA KEV since 2025-04-01; CISA due date 2025-04-22
- EPSS: 99.94%
- Public exploit code: 1 on Exploit-DB · 1 Metasploit module · 60 GitHub proofs of concept · 1 Nuclei template (first 2025-03-13)
- CISA SSVC: exploitation active, automatable no, technical impact total (assessed 2025-04-01)
- Weakness: CWE-44, CWE-502
- Also known as: GHSA-83qj-6fr2-vhqg
- Published: 2025-03-10

## Affected versions

- Apache Software Foundation Apache Tomcat: affected >= 11.0.0-M1 and <= 11.0.2; >= 10.1.0-M1 and <= 10.1.34; >= 9.0.0.M1 and <= 9.0.98; >= 8.5.0 and <= 8.5.100; >= 3 and < 8.5.0; >= 10.0.0-M1 and <= 10.0.27

A version outside these ranges is not a statement that it is unaffected.

## References

- [advisory] https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq
- [other] http://www.openwall.com/lists/oss-security/2025/03/10/5
- [other] https://www.vicarius.io/vsociety/posts/cve-2025-24813-detect-apache-tomcat-rce
- [other] https://www.vicarius.io/vsociety/posts/cve-2025-24813-mitigate-apache-tomcat-rce
- [other] https://security.netapp.com/advisory/ntap-20250321-0001/
- [other] https://lists.debian.org/debian-lts-announce/2025/04/msg00003.html
- [other] https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-detect-vulnerability
- [other] https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnerability
- [exploit] https://github.com/absholi7ly/POC-CVE-2025-24813/blob/main/README.md
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24813

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
