Skip to content
vulnerability

CVE-2025-24813

9.8
Critical
KEV · Exploited in wildEPSS 100%Patch available

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

exploited
Yes, in CISA KEV since 1 Apr 2025fix by 22 Apr 2025 (CISA deadline for US federal agencies)public exploit code
fix
Patch available see the advisory in the references
likelihood
EPSS 99.9%
Published 10 Mar 2025Analysed here 2 Nov 2026

do firstApply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

triage

Can a WAF block it? Partly. Cloudflare publishes WAF a rule written for this CVE. Such rules block the known exploit requests and buy time, but attackers can change the request to get past them, so they do not replace the patch.

Also consider: patch · enable the vendor rule in block mode · allow-list classes

Based on WAF vendor rules published for this CVE. We check Cloudflare, AWS, Google Cloud Armor and Azure; for Akamai, Imperva, Fastly, F5, ask your vendor.

cvss vector
attack vectornetworkattack complexitylowprivileges requirednoneuser interactionnonescopeunchangedconfidentialityhighintegrityhighavailabilityhigh
CVSS 3.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
common questions

Is CVE-2025-24813 being exploited?

Yes. CVE-2025-24813 appears in CISA's Known Exploited Vulnerabilities catalog, which means exploitation in the wild has been confirmed and reported. Treat it as active rather than theoretical, and patch it ahead of higher-scoring vulnerabilities that carry no exploitation evidence.

How severe is CVE-2025-24813?

CVE-2025-24813 is rated Critical with a CVSS score of 9.8. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2025-24813?

Yes. A fix has been recorded for CVE-2025-24813. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2025-24813 affect?

CVE-2025-24813 affects apache:tomcat, debian:debian_linux, netapp:bootstrap_os. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
apache:tomcatdebian:debian_linuxnetapp:bootstrap_os
affected versions
Apache Software Foundation Apache Tomcat
  • affected>= 11.0.0-M1 and <= 11.0.2
  • affected>= 10.1.0-M1 and <= 10.1.34
  • affected>= 9.0.0.M1 and <= 9.0.98
  • affected>= 8.5.0 and <= 8.5.100
  • affected>= 3 and < 8.5.0
  • affected>= 10.0.0-M1 and <= 10.0.27

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

public exploits

Public exploit code: 1 on Exploit-DB · 1 Metasploit module · 60 GitHub proofs of concept · 1 Nuclei template

Listed so you can judge urgency, not as a recommendation to run anything. GitHub “proofs of concept” are unvetted: some are fake or carry malware. Exploit-DB marks the entries its staff verified.

cisa ssvc

exploitation
active
automatable
no
technical impact
total

Assessed by CISA 1 Apr 2025 (SSVC 2.0.3).

timeline

  1. 10 Mar 2025Published
  2. 13 Mar 2025First public exploit or proof of concept · 2 days later
  3. 1 Apr 2025Added to CISA KEV (exploited in the wild) · 19 days later
  4. 1 Apr 2025CISA SSVC assessment: exploitation active · 1 day later
  5. 22 Apr 2025CISA remediation due date (US federal agencies) · 20 days later
  6. 29 Oct 2025CVE record last updated · 190 days (about 6 months) later
  7. 2 Nov 2026Analysed by vulneraibility.com · 369 days (about 1 year) later

also known as

how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
10 references in the CVE record: 1 advisory, 1 exploit, 8 links
Show 2 more
  • Linkvicarius.io /vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnerability
  • Linkcisa.gov /known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24813

sources

get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved