# CVE-2024-56145

Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.

- Page: https://www.vulneraibility.com/cve/CVE-2024-56145
- CVSS: 9.8
- Known exploited: yes, in CISA KEV since 2025-06-02; CISA due date 2025-06-23
- EPSS: 97.48%
- Public exploit code: 1 Metasploit module · 3 GitHub proofs of concept · 1 Nuclei template (first 2024-12-20)
- CISA SSVC: exploitation active, automatable yes, technical impact total (assessed 2025-06-06)
- Weakness: CWE-94
- Also known as: GHSA-2p6p-9rc9-62j9
- Published: 2024-12-18

## Affected versions

- craftcms cms: affected >= 4.0.0-RC1 and < 4.13.2; >= 5.0.0-RC1 and < 5.5.2; >= 3.0.0 and < 3.9.14

A version outside these ranges is not a statement that it is unaffected.

## References

- [other] https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9
- [other] https://github.com/craftcms/cms/commit/82e893fb794d30563da296bca31379c0df0079b3
- [exploit] https://github.com/Chocapikk/CVE-2024-56145
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-56145

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
