Skip to content
vulnerability

CVE-2024-53197

7.8
High
KEV · Exploited in wildEPSS 4%Patch available

In the Linux kernel, the following vulnerability has been resolved: ALSA: usb-audio: Fix potential out-of-bound accesses for Extigy and Mbox devices A bogus device can provide a bNumConfigurations value that exceeds the initial value used in usb_get_configuration for allocating dev->config. This can lead to out-of-bounds accesses later, e.g. in usb_destroy_configuration.

exploited
Yes, in CISA KEV since 9 Apr 2025fix by 30 Apr 2025 (CISA deadline for US federal agencies)
fix
Fixed in < 2.6.12, >= 4.19.325 and <= 4.19.*, >= 5.4.287 and <= 5.4.* +7
likelihood
EPSS 4.1%
Published 27 Dec 2024Analysed here 2 Nov 2026CVSS scored by CISA

do firstUpgrade to a fixed release: < 2.6.12, >= 4.19.325 and <= 4.19.*, >= 5.4.287 and <= 5.4.*, >= 5.10.231 and <= 5.10.* (+6 more below).

triage
server-sideruntimeWAF can block: noAV · localCWE-787· Out-of-Bounds Write

Can a WAF block it? No. The attack needs local access to the machine, so a WAF is not on its path.

Also consider: patch

Based on the attack vector (local or physical access). We check Cloudflare, AWS, Google Cloud Armor and Azure; for Akamai, Imperva, Fastly, F5, ask your vendor.

cvss vector
attack vectorlocalattack complexitylowprivileges requiredlowuser interactionnonescopeunchangedconfidentialityhighintegrityhighavailabilityhigh
CVSS 3.1 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
common questions

Is CVE-2024-53197 being exploited?

Yes. CVE-2024-53197 appears in CISA's Known Exploited Vulnerabilities catalog, which means exploitation in the wild has been confirmed and reported. Treat it as active rather than theoretical, and patch it ahead of higher-scoring vulnerabilities that carry no exploitation evidence.

How severe is CVE-2024-53197?

CVE-2024-53197 is rated High with a CVSS score of 7.8. Severity describes how bad exploitation would be, not how likely it is: pair it with exploitation evidence before deciding what to patch first.

Is there a patch for CVE-2024-53197?

Yes. A fix has been recorded for CVE-2024-53197. The vendor advisory is the authority on the exact fixed version — apply it from there rather than from a summary.

What does CVE-2024-53197 affect?

CVE-2024-53197 affects linux:linux_kernel, debian:debian_linux. Confirm the exact affected versions against the vendor advisory before deciding you are exposed.

Exploitation status reflects CISA's KEV catalog as we last synced it. Check the catalog directly.

executive summary
technical analysis
affected
linux:linux_kerneldebian:debian_linux
affected versions
Linux
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < 0b4ea4bfe16566b84645ded1403756a2dc4e0f19
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < 9b8460a2a7ce478e0b625af7c56d444dc24190f7
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < 62dc01c83fa71e10446ee4c31e0e3d5d1291e865
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < 9887d859cd60727432a01564e8f91302d361b72b
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < 920a369a9f014f10ec282fd298d0666129379f1b
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < b8f8b81dabe52b413fe9e062e8a852c48dd0680d
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < 379d3b9799d9da953391e973b934764f01e03960
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < b521b53ac6eb04e41c03f46f7fe452e4d8e9bcca
  • affected>= 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2 and < b909df18ce2a998afef81d58bbd1a05dc0788c40
  • affected2.6.12
vendor says fixed in< 2.6.12, >= 4.19.325 and <= 4.19.*, >= 5.4.287 and <= 5.4.*, >= 5.10.231 and <= 5.10.*, >= 5.15.174 and <= 5.15.*, >= 6.1.120 and <= 6.1.*, >= 6.6.64 and <= 6.6.*, >= 6.11.11 and <= 6.11.*, >= 6.12.2 and <= 6.12.*, >= 6.13 and <= *

As published in the CVE Program record. A version outside these ranges is not a statement that it is unaffected — vendors sometimes understate a range, and distribution-backported builds carry upstream numbers that do not reflect what was patched into them.

cisa ssvc

exploitation
active
automatable
no
technical impact
total

Assessed by CISA 9 Apr 2025 (SSVC 2.0.3).

timeline

  1. 27 Dec 2024Published
  2. 9 Apr 2025Added to CISA KEV (exploited in the wild) · 102 days (about 3 months) later
  3. 9 Apr 2025CISA SSVC assessment: exploitation active · 1 day later
  4. 30 Apr 2025CISA remediation due date (US federal agencies) · 20 days later
  5. 11 May 2026CVE record last updated · 377 days (about 1 year) later
  6. 2 Nov 2026Analysed by vulneraibility.com · 175 days (about 6 months) later
how to fix
Remediation steps are tailored for users whose stack is affected. Add this technology to your stack to see the fix checklist.
references
12 references in the CVE record: 12 links
Show 4 more
  • Linkgit.kernel.org /stable/c/b909df18ce2a998afef81d58bbd1a05dc0788c40
  • Linkcisa.gov /known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-53197
  • Linklists.debian.org /debian-lts-announce/2025/03/msg00001.html
  • Linklists.debian.org /debian-lts-announce/2025/03/msg00002.html

sources

  • CVE List (CVE.org): description, affected versions, references; CVE Terms of Use
  • NVD: CVSS and CPE data
  • CISA KEV catalog: exploitation, date added, due date
  • CISA Vulnrichment (ADP): SSVC decision points
  • FIRST EPSS: exploit probability and percentile
  • Summary, impact and triage tags: written by our AI analysis pipeline from the sources above. Check them against the sources.
get alerted

Track only the vulnerabilities that affect your infrastructure.

start for free

© 2026 vulneraibility.com, all rights reserved