# CVE-2024-38856

Incorrect Authorization vulnerability in Apache OFBiz. This issue affects Apache OFBiz: through 18.12.14. Users are recommended to upgrade to version 18.12.15, which fixes the issue. Unauthenticated endpoints could allow execution of screen rendering code of screens if some preconditions are met (such as when the screen definitions don't explicitly check user's permissions because they rely on the configuration of their endpoints).

- Page: https://www.vulneraibility.com/cve/CVE-2024-38856
- CVSS: 9.8
- Known exploited: yes, in CISA KEV since 2024-08-27; CISA due date 2024-09-17
- EPSS: 99.43%
- Public exploit code: 1 Metasploit module · 9 GitHub proofs of concept · 1 Nuclei template (first 2024-08-08)
- CISA SSVC: exploitation active, automatable yes, technical impact total (assessed 2024-08-31)
- Weakness: CWE-863
- Published: 2024-08-05

## Affected versions

- Apache Software Foundation Apache OFBiz: affected <= 18.12.14

A version outside these ranges is not a statement that it is unaffected.

## References

- [mitigation] https://ofbiz.apache.org/download.html
- [other] https://ofbiz.apache.org/security.html
- [advisory] https://lists.apache.org/thread/olxxjk6b13sl3wh9cmp0k2dscvp24l7w
- [other] https://issues.apache.org/jira/browse/OFBIZ-13128
- [other] http://www.openwall.com/lists/oss-security/2024/08/04/1
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-38856

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
