# CVE-2024-27348

RCE-Remote Command Execution vulnerability in Apache HugeGraph-Server.This issue affects Apache HugeGraph-Server: from 1.0.0 before 1.3.0 in Java8 & Java11 Users are recommended to upgrade to version 1.3.0 with Java11 & enable the Auth system, which fixes the issue.

- Page: https://www.vulneraibility.com/cve/CVE-2024-27348
- CVSS: 9.8
- Known exploited: yes, in CISA KEV since 2024-09-18; CISA due date 2024-10-09
- EPSS: 99.21%
- Public exploit code: 1 on Exploit-DB · 1 Metasploit module · 6 GitHub proofs of concept · 1 Nuclei template (first 2024-05-31)
- CISA SSVC: exploitation active, automatable yes, technical impact total (assessed 2024-09-25)
- Weakness: CWE-284
- Also known as: GHSA-29rc-vq7f-x335
- Published: 2024-04-22

## Affected versions

- Apache Software Foundation Apache HugeGraph-Server: affected >= 1.0.0 and < 1.3.0

A version outside these ranges is not a statement that it is unaffected.

## References

- [other] https://hugegraph.apache.org/docs/config/config-authentication/#configure-user-authentication
- [advisory] https://lists.apache.org/thread/nx6g6htyhpgtzsocybm242781o8w5kq9
- [other] http://www.openwall.com/lists/oss-security/2024/04/22/3
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-27348
- [other] https://www.vicarius.io/vsociety/posts/remote-code-execution-vulnerability-in-apache-hugegraph-server-cve-2024-27348

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
