# CVE-2021-21311

Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.

- Page: https://www.vulneraibility.com/cve/CVE-2021-21311
- CVSS: 7.2
- Known exploited: yes, in CISA KEV since 2025-09-29; CISA due date 2025-10-20
- EPSS: 98.46%
- Unvetted proof-of-concept code on GitHub: 3 GitHub proofs of concept · 1 Nuclei template (first 2022-02-14)
- CISA SSVC: exploitation active, automatable yes, technical impact partial (assessed 2025-09-27)
- Weakness: CWE-918
- Also known as: GHSA-x5r2-hj5c-8jx6
- Published: 2021-02-11

## Affected versions

- vrana adminer: affected >= 4.0.0 and < 4.7.9

A version outside these ranges is not a statement that it is unaffected.

## References

- [other] https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6
- [other] https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf
- [other] https://packagist.org/packages/vrana/adminer
- [other] https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351
- [other] https://lists.debian.org/debian-lts-announce/2021/03/msg00002.html
- [other] https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-21311

---
Summary, impact and action are written by the vulneraibility.com AI analysis pipeline from the CVE record, NVD, CISA and FIRST data; verify against the references.
